Premiers contacts avec AlternC
Comment gérer votre compte web sur AlternC, l’interface d’administration en ligne.
Formulaire d’envoi de mail, en toute sécurité
Envoyer des messages depuis le web sans risque.
Globenet supporte PHP5
Depuis janvier 2010, le service d’hébergement mutualisé supporte le PHP5. Pour mettre en oeuvre (...)
Eté 2010 : fin du support de PHP4
Article réactualisé le jeudi 16 septembre 2010 Cet été, les serveurs de l’offre d’hébergement (...)
Anti-spam : le greylisting
Méthode anti-spam qui se refuse à scanner vos courriels.
Certificats de sécurité
Carte d’identité pour les ordinateurs, certifiant leur identité.
Eté 2010 : fin du support de PHP4

Article réactualisé le jeudi 16 septembre 2010

Cet été, les serveurs de l’offre d’hébergement mutualisé de Globenet vont subir une importante mise à jour. Cela vous concerne si vous avez un compte d’hébergement Globenet.

La disponibilité de PHP4 se terminera d’ici le 15 OCTOBRE 2010.

Si vos applications internet (Spip, Joomla, Drupal, etc.) sont régulièrement mises à jours, aucun problème.

Si votre site utilise un CMS qui n’a pas été mis à jour depuis les 3 ou 4 dernières années, il va falloir vous en préoccuper sérieusement.

LES ÉTAPES DU CHANGEMENT

Depuis janvier de cette année il est déjà possible d’utiliser PHP5 avec vos applications à condition d’ajouter un bout de code particulier dans votre site internet. C’est expliqué là.

A partir du 17 septembre, la procédure s’inverse : c’est pour utiliser PHP4 que vous devrez ajouter un bout de code. La manœuvre peut vous être communiquée si vous ne la connaissez pas encore.

Enfin à partir du 15 OCTOBRE, il ne sera plus possible d’utiliser PHP4. Vos applications devront avoir été mises à jour pour fonctionner sur nos serveurs.

Bien sûr, si vous avez besoin d’aide, si vous n’avez plus de webmaster capable de réaliser la mise à jour de votre site internet, nous tâcherons, comme à notre habitude, de vous aider.

PHP5 versus PHP4

Depuis 6 ans, PHP a changé de version, passant de PHP4 à PHP5 : http://www.siteduzero.com/news-62-1... Ce langage est à la base de la plupart des logiciels CMS que vous utilisez (Spip, Joomla, Drupal, etc.).

PHP5 a mis longtemps a être adopté par les CMS, mais aujourd’hui toutes les dernières versions exploitent les nouvelles fonctionnalités disponibles dans PHP5.

Enfin le support de PHP4 est terminé depuis maintenant 3 ans et la dernière version de Debian (l’OS qui fait tourner nos serveurs) ne permet pas d’utiliser PHP4.

AU DELÀ DE PHP5

L’enjeu de ce changement de version de PHP, c’est la mise à jour de nos équipements. Il est aujourd’hui absolument nécessaire de faire évoluer nos équipements et notamment de mettre à jour nos serveurs. Notamment en installant la version courante de l’OS DEBIAN sur nos machines de production. C’est une question de sécurité et de performance pour les services internet que vous avez mis en œuvre à partir de nos machines.

Une deuxième conséquence de cette évolution consistera à faire évoluer l’interface de gestion de votre compte. Les fonctionnalités disponibles dans cette interface resteront les mêmes, apparemment en plus joli (!) mais par en dessous plus efficace. Et la possibilité de vous proposer petit à petit de nouveaux services.